Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 21, 2026 - 08:00 BST
Scheduled
Nottingham College is launching a new Live Chat system replacing the current system in use on the Nottingham College website. This will be going live on Tuesday 21st July from 8:30 am. No user action is required as the switch will happen automatically for all users. If you have previously used our Live Chat service, the new system will look different but offers more advanced capabilities and knowledge to provide better help and support for topics around Nottingham College.
Posted Jul 17, 2026 - 16:12 BST
This scheduled maintenance affected: College Website (www.nottinghamcollege.ac.uk).